Support update for MetaTrader Platforms on Windows XP/2003/Vista

  • 29 Sep 2017

We would like to inform you that MetaTrader platforms will no longer support Windows XP, Windows 2003 and Windows Vista after 01 October 2017.

This is due to the limitations of outdated operating systems of Windows XP, 2003 and Vista in their technical capabilities and they have dangerous vulnerabilities.

Older versions of MetaTrader 4 and MetaTrader 5 will continue to work on these systems, but will not be able to receive updates after 01 October 2017. Also, installers will not run on these operating systems.

The minimum required operating system version for running MetaTrader 4/5 will be Windows 7. However, it is strongly recommended to use the 64-bit versions of Windows 10.

Sign up to get started

LIQUIDITY
PROVIDERS
Demo Account »
Anzo Account »
Promotions Promotions
Promotions